返回首页
当前位置: Novell迷 > 站长博客 >

涨停跌停K线高亮显示的标识公式

时间:2020-10-15 23:02来源:未知 作者:Novell迷 点击:
公式可以自动区分老涨停(10%)和新涨停(20%),还可以标识炸板和撬板。 公式基于通达信。供参考,如果喜欢或者觉得有帮助,就点个赞扬吧。 {K线图着重显示涨跌停} BK:=IF(INBLOCK(

 公式可以自动区分老涨停(10%)和新涨停(20%),还可以标识炸板和撬板。 Novell迷网站內容,版权所有

公式基于通达信。供参考,如果喜欢或者觉得有帮助,就点个赞扬吧。
 
{K线图着重显示涨跌停}
BK:=IF(INBLOCK('科创板'),0.2,IF(INBLOCK('创业板'),0.2,IF(INBLOCK('ST板块'),0.05,0.1)));
XA_1:=IF(DATE<=1200823,1,0);
旧涨停:=(C>=ZTPRICE(REF(CLOSE,1),0.1) AND C=H) AND XA_1=1;
旧跌停:=(C<=DTPRICE(REF(CLOSE,1),0.1) AND C=L) AND XA_1=1;
涨停:=C>=ZTPRICE(REF(C,1),BK) AND C=H;
跌停:=C<=DTPRICE(REF(C,1),BK) AND C=L;
曾涨停:=(H>=ZTPRICE(REF(C,1),BK) AND C<H) OR (H>=ZTPRICE(REF(CLOSE,1),0.1) AND C<H AND XA_1=1);
曾跌停:=(L<=DTPRICE(REF(C,1),BK) AND C>L) OR (L<=DTPRICE(REF(CLOSE,1),0.1) AND C>L AND XA_1=1);
STICKLINE(旧涨停 AND PERIOD=5,O,C,4,0),COLORYELLOW;
STICKLINE(旧跌停 AND PERIOD=5,O,C,4,0),COLORGREEN;
STICKLINE(涨停 AND PERIOD=5,C,O,4,0),COLORYELLOW;
STICKLINE(跌停 AND PERIOD=5,C,O,4,0),COLORGREEN;
STICKLINE(曾涨停 AND PERIOD=5,H,L,0.1,0),COLORYELLOW;{涨停后回落}
STICKLINE(曾跌停 AND PERIOD=5,L,H,0.1,0),COLORGREEN;{跌停后回升}
DRAWTEXT(旧涨停 AND PERIOD=5,L-0.1,'涨停'),COLORYELLOW;
DRAWTEXT(旧跌停 AND PERIOD=5,H+0.2,'跌停'),COLORGREEN;
DRAWTEXT(涨停 AND PERIOD=5,L-0.1,'涨停'),COLORYELLOW;
DRAWTEXT(跌停 AND PERIOD=5,H+0.2,'跌停'),COLORGREEN;
DRAWTEXT(曾涨停 AND PERIOD=5,H+0.2,'炸板'),COLORGREEN;
DRAWTEXT(曾跌停 AND PERIOD=5,L-0.1,'撬板'),COLORYELLOW;
转载请注明出处!
本文地址 http://novell.me/master-diary/2020-10-15/587.html
(责任编辑:Novell迷)
对我有帮助
(0)
0%
没什么帮助
(0)
0%
------分隔线----------------------------
发表评论
验证码:点击我更换图片
赞助商链接